Question:

Operating Systems Supported for the LSI 3ware and MegaRAID Controllers

Answer:



Controller Family
Models
           
 

LSI 3ware
  • 7000 series Parallel ATA RAID controller
  •                
  • 8000/9500S series Serial ATA RAID controller
  •                
  • 9550SX(U) series Serial ATA II RAID controller
  •                
  • 9650SE series RAID 6 PCIe Serial ATA II RAID controller
  •                
  • 9690SA PCIe SAS/SATA RAID controller
  •                
  • 9750 PCIe SAS/SATA RAID controller 
  •            
           

           
           
LSI MegaRAID
            (see also 3GB & 6GB official lists)
           
           
           
                   
  • MegaRAID SAS 8204 / 8208
  •                
  • MegaRAID SAS 84016E
  •                
  • MegaRAID SAS 8704 / 8708 / 8888
  •                
  • MegaRAID SAS 9240
  •                
  • MegaRAID SAS 9260 / 9261
  •                
  • MegaRAID SAS 9280
  •            
           

has support for the following operating systems.



                                                                                                       
Windows  Linux 
           
FreeBSD 
           
OpenSolaris 
           
MacOS 
           
VMware
           



Windows
LSI 3ware and LSI MegaRAID Controllers

(see Microsoft's compatibility page for 3ware)(see Microsoft's compatibility page for LSI MegaRAID and SAS HBAs and here)
(For LSI 3ware controllers, use the management software 3DM2 / CLI from the latest available code set, e.g. 10.2 code set 3DM2/CLI, 10.2 code set CLI only)
[For LSI MegaRAID controllers, use the latest available management software MegaRAID Storage Manager (MSM) / MegaCLI]



Windows Operating System Version 
           

Controller Family 
           

Comments
            (note: both 32-bit and 64-bit support is available unless otherwise stated)

 

Windows 2000 (no SP, SP1, SP2, or SP3)

 Not supported.

 A minimum level of W2K Service Pack 4 (SP4) is required.

 

           



Windows 2000 SP4 or newer
sp;



MegaRAID Controllers

 Not supported.

 

7000/8000

Supported with 7.7.1 code setdrivers (7.7.1 drivers only)

 

 9500S/9550SX(U)/9590SE

Supported with the9.3.0.7 code set drivers (9.3.0.7 drivers only)

 

 9650SE/9690SA/9750

 Not supported.

 

WindowsMillennium
           

 Not supported.

 

 

 Windows XP no SP

 Not supported.

 A minimum level of Windows XP Service Pack 1 (SP1) is required

 

  



            Windows XP SP1 or newer

 7000/8000

Supported with the7.7.1 code set drivers (7.7.1 drivers only)

 

 9500S/9550SX(U)/9590SE/9650SE/9690SA

Supported with the9.5.3 code set drivers

 

 9750

Unsupported
           

 

 MegaRAID SAS 8204 / 8208 
            MegaRAID SAS 84016E 
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280-4i4e / 8e / DE-8e
            MegaRAID SAS 9280-16i4e / 24i4e


            
            
            Supported; click product to view its download page

 

 
            
            
            
            
                       

Windows 2003 (WK3) no SP, or SP1

           

 7000/8000

Supported with 7.7.1 code setdrivers (7.7.1 drivers only)

 

 9500S/9550SX(U)/9590SE/9650SE/9690SA

Supported with the9.5.3 code set drivers

 

 9750

Not supported;  see KB A007259-082812

 

 MegaRAID SAS 8204 / 8208 
            MegaRAID SAS 84016E 
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280-4i4e / 8e / DE-8e
            MegaRAID SAS 9280-16i4e / 24i4e


            
            
            Supported; click product to view its download page

 


            
            
            
            
           

 Windows 2003 (WK3) SP2

           

 7000/8000

Supported with 7.7.1 code setdrivers (7.7.1 drivers only)

 

 9500S/9550SX(U)/9590SE/9650SE/9690SA

Supported with the9.5.3 code set drivers

 

 9750

Supported with the 10.2 code setdrivers

 

 MegaRAID SAS 8204 / 8208 
            MegaRAID SAS 84016E 
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280-4i4e / 8e / DE-8e
            MegaRAID SAS 9280-16i4e / 24i4e


            
            
            Supported; click product to view its download page

 


            
            
            
            
           

 Windows 2008/Vista

           

 7000/8000

Supported with 7.7.1 code setdrivers (7.7.1 drivers only)

 

 9500S/9550SX(U)/9590SE/9650SE/9690SA

Supported with the9.5.3 code set drivers

 

 9750

Supported with the 10.2 code setdrivers

 

 MegaRAID SAS 8204 / 8208 
            MegaRAID SAS 84016E 
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280-4i4e / 8e / DE-8e
            MegaRAID SAS 9280-16i4e / 24i4e

 
            
            
            Supported; click product to view its download page

 


            
            
            
           Windows 2008 R2*
            
(latest version of the controller firmware must be used; click on the controller model on right to download)
           

 7000/8000

Supported with 7.7.1 code setdrivers (7.7.1 drivers only)

 

 9500S/9550SX(U)/9590SE/9650SE/9690SA

Supported with the9.5.3 code set drivers

 

 9750

Supported with the 10.2 code setdrivers

 

 MegaRAID SAS 8204 / 8208 
            MegaRAID SAS 84016E 
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280-4i4e / 8e / DE-8e
            MegaRAID SAS 9280-16i4e / 24i4e

 
            
            Supported; click product to view its download page

 

 
            
            
            
            Windows 7*
            
            
            
            
            
*For LSI 3ware controllers it is highly recommended 
            that you use the latest version of the controller firmware.  
            Some controllers [e.g. 9550SX(U)] won't work unless 
            you have the latest firmware in your controller.  KB A005215-082812

 7000/8000

 Not supported.
           

 

 9500S/9550SX(U)/9590SE/9650SE/9690SA

Supported with the9.5.3 code set drivers

 

 9750

Supported with the 10.2 code setdrivers

 

 MegaRAID SAS 8204 / 8208 
MegaRAID SAS 84016E 
MegaRAID SAS 8704 / 8708 / 8888
MegaRAID SAS 9240
; MegaRAID SAS 9260 / 9261
MegaRAID SAS 9280-4i4e / 8e / DE-8e
MegaRAID SAS 9280-16i4e / 24i4e




Supported; click product to view its download page

 

 7000/8000

 Not supported.
           

 

 9500S/9550SX(U)/9590SE/9650SE/9690SA

Supported with the9.5.3 code set drivers

 

Windows Server 2012/Windows 8

3ware Controllers

Not yet supported

MegaRAID SAS 9240

MegaRAID SAS 9260 / 9261 / 9266

MegaRAID 9270 / 9271

MegaRAID SAS 9280 / 9286

Supported; click product to view its download page





Linux (sorted alphabetically)
LSI 3ware and LSI MegaRAID Controllers
(LSI 3ware controllers: use the management software 3DM2 / CLI from the latest available code set, e.g. 10.2 code set 3DM2/CLI and CLI only)
(LSI MegaRAID controllers: use the management software MegaRAID Storage Manager / MegaCLI from the latest available code release, e.g. MegaRAID Release 5.0)


Native support included
 Linux Distribution
           
 Kernel  Controller Family
           
 Comments
 Linux kernels 2.4.3 and newer, and all 2.6 kernels    7000/8000  Native support included; use the latest available 3DM2/CLI           
 Linux kernels 2.6.8 and newer    7000/8000/9500S  Native support included; use the latest available 3DM2/CLI           
 Linux kernels 2.6.14 and newer    7000*/8000*/9500S/9550SX(U)/9590SE  Native support included; use the latest available 3DM2/CLI           
 Linux kernels 2.6.19 and newer    7000*/8000*/9500S/9550SX(U)/9590SE/9650SE  Native support included; use the latest available 3DM2/CLI
 Linux kernels 2.6.23 and newer    7000/8000/9500S/9550SX(U)/9590SE/9650SE/9690SA  Native support included; use the latest available 3DM2/CLI
 Linux kernels 2.6.23 and newer    7000/8000/9500S/9550SX(U)/9590SE/9650SE/9690SA  Native support included; use the latest available 3DM2/CLI
 Linux kernels 2.6.33 and newer    7000/8000/9500S/9550SX(U)/9590SE/9650SE/9690SA/9750  Native support included; use the latest available 3DM2/CLI
 Linux kernels 2.4.3 and newer, and all 2.6 kernels   MegaRAID SAS 8204 / 8208
            MegaRAID SAS 84016E
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280
 While native driver support is included in many kernels, it should not be used and is not supported;  only the drivers for the specific releases of Linux listed here are supported
ClarkConnect 3.2 2.6.9-27.cc  7000/8000  Native support included
ClarkConnect 3.2 2.6.9-27.cc  9550SX(U)/9590SE Supported with KB A007433-082812 driver
ClarkConnect 3.2 2.6.9-27.cc  9650SE/9690SA Email request for support to support@lsi.com
ClarkConnect 3.2 2.6.9-27.cc  9750 Email request for support to support@lsi.com
ClarkConnect Community Edition v4.0 and v4.1 SP1   2.6.9-42.cc  7000/8000  Native support included
ClarkConnect Community Edition v4.0 and v4.1 SP1   2.6.9-42.cc  9500S/9550SX(U)/9590SE/9650SE Supported with KB A007434-082812  driver
ClarkConnect Community Edition v4.0 and v4.1 SP1   2.6.9-42.cc  9690SA Email request for support to support@lsi.com
ClarkConnect Community Edition v4.0 and v4.1 SP1   2.6.9-42.cc  9750 Email request for support to support@lsi.com
ClarkConnect Community Edition v4.2 SP1  2.6.18-53.1.13.2.cc  7000/8000  Native support included
ClarkConnect Community Edition v4.2 SP1  2.6.18-53.1.13.2.cc  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007435-082812 driver
ClarkConnect Community Edition v4.2 SP1  2.6.18-53.1.13.2.cc  9750 Email request for support to support@lsi.com
ClarkConnect Community Edition v4.3  2.6.18-92.cc  7000/8000  Native support included
ClarkConnect Community Edition v4.3  2.6.18-92.cc  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007436-082812 driver
ClarkConnect Community Edition v4.3  2.6.18-92.cc  9750 Email request for support to support@lsi.com
 ClearOS 5.2 Enterprise Edition           

           
 2.6.18-194.8.1.v5  9500S/9550SX(U)/9590SE/9650SE/9690SA/9750 Supported with KB A007699-082812 driver
 ClearOS 5.2 Enterprise Edition           

           
 2.6.18-194.8.1.v5 MegaRAID SAS 8204 / 8208
            MegaRAID SAS 84016E
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280
 Supported with this driver.
Debian Linux Sarge 3.1 2.4.27 and 2.6.8  7000/8000  Native support included
Debian Linux Sarge 3.1 2.4.27 and 2.6.8  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007430-082812 driver
Debian Linux Sarge 3.1 2.4.27 and 2.6.8  9750 Email request for support to support@lsi.com
 Debian Linux 4.0 Etch  2.6.18  7000/8000  Native support included
 Debian Linux 4.0 Etch  2.6.18  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007431-082812 driver
 Debian Linux 4.0 Etch  2.6.18  9750 Email request for support to support@lsi.com
 Debian Linux Lenny 5.3 (aka 5.0.3/5.0.4/5.0.5 all have the same kernel version) 2.6.26-2-686  7000/8000  Native support included
 Debian Linux Lenny 5.3 (aka 5.0.3/5.0.4/5.0.5 all have the same kernel version) 2.6.26-2-686  9500S/9550SX(U)/9590SE/9650SE/9690SA/9750 Supported with KB A007432-082812 driver
 Debian Linux Lenny 5.3 (aka 5.0.3/5.0.4/5.0.5 all have the same kernel version) 2.6.26-2-686 MegaRAID SAS 8204 / 8208
            MegaRAID SAS 84016E
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280
 Supported with the MegaRAID Release 5.0 driver
           
 Fedora Core 1  2.4.22-1.2115  7000/8000  Native support included
 Fedora Core 1  2.4.22-1.2115  9500S/9550SX(U)/9590SE Supported with KB A007375-082812 driver
 Fedora Core 1  2.4.22-1.2115  9650SE/9690SA Email request for support to support@lsi.com
 Fedora Core 1  2.4.22-1.2115  9750  Support not available for the 9750 for 2.4 linux kernel distros
           
Fedora Core 2 2.6.5-1  7000/8000  Native support included
Fedora Core 2 2.6.5-1  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007393-082812 driver
Fedora Core 2 2.6.5-1  9750 Email request for support to support@lsi.com
Fedora Core 3 2.6.9-1.667  7000/8000  Native support included
Fedora Core 3 2.6.9-1.667  9500S/9550SX(U)/9590SE/9650SE Supported with KB A007394-082812 driver
Fedora Core 3 2.6.9-1.667  9690SA Email request for support to support@lsi.com
Fedora Core 3 2.6.9-1.667  9750 Email request for support to support@lsi.com
 Fedora Core 4  2.6.11-1.369  7000/8000  Native support included
 Fedora Core 4  2.6.11-1.369  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007395-082812 driver
 Fedora Core 4  2.6.11-1.369  9750 Email request for support to support@lsi.com
 Fedora Core 5  2.6.16  7000/8000  Native support included
 Fedora Core 5  2.6.16  9500S/9550SX(U)/9590SE/9650SE Supported with KB A007396-082812 driver
 Fedora Core 5  2.6.16  9690SA Email request for support to support@lsi.com
 Fedora Core 5  2.6.16  9750 Email request for support to support@lsi.com
Fedora Core 2.6.18  7000/8000  Native support included
Fedora Core 2.6.18  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007397-082812 driver
Fedora Core 2.6.18  9750 Email request for support to support@lsi.com
 Fedora Core 7 2.6.21-1.3194.FC7  7000/8000  Native support included
 Fedora Core 7 2.6.21-1.3194.FC7  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007398-082812 driver
 Fedora Core 7 2.6.21-1.3194.FC7  9750 Email request for support to support@lsi.com
Fedora Core 8  2.6.23.1-42  7000/8000  Native support included
Fedora Core 8  2.6.23.1-42  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007399-082812 driver
Fedora Core 8  2.6.23.1-42  9750 Email request for support to support@lsi.com
Fedora Core 9  2.6.25  7000/8000  Native support included
Fedora Core 9  2.6.25  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007400-082812 driver
Fedora Core 9  2.6.25  9750 Email request for support to support@lsi.com                                                                                               
           
Fedora Core 10 2.6.27.5-117  7000/8000  Native support included
Fedora Core 10 2.6.27.9  7000/8000  Native support included
Fedora Core 10 2.6.27.9  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB15753 driver
Fedora Core 10 2.6.27.5-117  9500S/9550SX(U)/9590SE/9650SE/9690SA  Native support included
Fedora Core 10 2.6.27.5-117  9750 Supported with the drivers attached to KB A008188-082812
 Fedora Core 11  2.6.29  7000/8000/9500S/9550SX(U)/9590SE/9650SE/9690SA  Native support included
 Fedora Core 11  2.6.29  9750 Supported with KB A007408-082812 driver
 Fedora Core 12  2.6.31.5-127.fc12  7000/8000/9500S/9550SX(U)/9590SE/9650SE/9690SA  Native support included
 Fedora Core 12  2.6.31.5-127.fc12  9750 Supported with KB A007409-082812 driver
 Fedora Core 12  2.6.31.5-127.fc12 MegaRAID SAS 8204 / 8208
            MegaRAID SAS 84016E
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280

           
            Supported with the MegaRAID Release 5.0 driver
           
 Fedora Core 13  2.6.33  7000/8000/9500S/9550SX(U)/9590SE/9650SE/9690SA/9750  Native support included
 Fedora Core 13  2.6.33 MegaRAID SAS 8204 / 8208
            MegaRAID SAS 84016E
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280
Supported with this driver
 Mandriva 2009
           
 2.6.270x  7000/8000  Native support included
 Mandriva 2009
           
 2.6.270x  9500S/9550SX(U)/9590SE/9650SE/9690SA  Linux kernels 2.6.23 and newer include native support for the 3ware 7000/8000/9500S/9550SX(U)/9590SE/9650SE/9690SA series controllers.
 Mandriva 2009
           
 2.6.270x  9750 Email request for support to support@lsi.com
 Mandriva 2009
           
     
 Mandriva 2009
           
Supported Kernels :
            ===================
            2.6.27-server-0.rc8.2mnb i586
            2.6.27-server-0.rc8.2mnb x86_64
MegaRAID SAS 8204 / 8208
            MegaRAID SAS 84016E
            MegaRAID SAS 8704 / 8708 / 8888
            MegaRAID SAS 9240
            MegaRAID SAS 9260 / 9261
            MegaRAID SAS 9280
 
            Supported with the MegaRAID 5.0 Release driver
Oracle VM 2.1.2 2.6.18-8.1.15.1.16.EL5XEN  7000/8000  Native support included
Oracle VM 2.1.2 2.6.18-8.1.15.1.16.EL5XEN  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007120-082812 driver
Oracle VM 2.1.2 2.6.18-8.1.15.1.16.EL5XEN  9750 Email request for support to support@lsi.com
 Oracle VM 2.2  2.6.18-128.2.1.4.9.EL5XEN  7000/8000  Native support included
 Oracle VM 2.2  2.6.18-128.2.1.4.9.EL5XEN  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007237-082812 driver
 Oracle VM 2.2  2.6.18-128.2.1.4.9.EL5XEN  9750 Email request for support to support@lsi.com
 Oracle 4.7  2.6.9-78.0.0.0.1.EL  7000/8000  Native support included
 Oracle 4.7  2.6.9-78.0.0.0.1.EL  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007157-082812 driver
 Oracle 4.7  2.6.9-78.0.0.0.1.EL  9750 Email request for support to support@lsi.com
 RedHat  7.3
           
 2.4.18-3 7000/8000  Native support included
 RedHat  7.3
           
 2.4.18-3  9500S/9550SX(U)/9590SE/9650SE/9690SA Email request for support to support@lsi.com
 RedHat  7.3  2.4.18-3  9750  2.4 kernel not supported on the 9750
           
RedHat 8.0  2.4.18-14  7000/8000  Native support included
RedHat 8.0  2.4.18-14  9500S/9550SX(U)/9590SE/9650SE/9690SA Email request for support to support@lsi.com
 RedHat 8.0  2.4.18-14  9750  2.4 kernel not supported on the 9750
 RedHat 9.0
           
 2.4.20-8  7000/8000 Native support included
 RedHat 9.0  2.4.20-8  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A007151-082812 driver
 RedHat 9.0  2.4.20-8  9750  2.4 kernel not supported on the 9750
 RedHat AS/ES/WS 3 / CenTos 3.0
           
 2.4.21-4.EL  7000/8000  Native support included
 RedHat AS/ES/WS 3 / CenTos 3.0  2.4.21-4.EL  9500S/9550SX(U)/9590SE/9650SE/9690SA Supported with KB A006604-082812 driver
 RedHat AS/ES/WS 3 / CenTos 3.0  2.4.21-4.EL  9750  2.4 kernel not supported on the 9750
RedHat AS/ES/WS 3 (update 1) / CenTos 3.1  2.4.21-9.EL  7000/8000  Native support included
 RedHat AS/ES/WS 3 (update 1) / CenTos 3.1  2.4.21-9.EL  9500S/9550SX(U)/9590SE/9650SE Supported with KB A007476-082812 driver
 RedHat AS/ES/WS 3 (update 1) / CenTos 3.1  2.4.21-9.EL  9690SA Email request for support to support@lsi.com
 RedHat AS/ES/WS 3 (update 1) / CenTos 3.1  2.4.21-9.EL  9750  2.4 kernel not supported on the 9750
 RedHat AS/ES/WS 3 (update 2) / CenTos 3.2  2.4.21-15.EL  7000/8000  Native support included
  RedHat AS/ES/WS 3 (update 2) / CenTos 3.2  2.4.21-15.EL  9500S/9550SX(U)/9590SE/9650SE Supported with KB A007353-082812 driver

           
     
 RedHat AS/ES/WS 3 (update 2) / CenTos 3.2  2.4.21-15.EL  9690SA Email request for support to support@lsi.com
 RedHat AS/ES/WS 3 (update 2) / CenTos 3.2  2.4.21-15.EL  9750  2.4 kernel not supported on the 9750
 RedHat AS/ES/WS 3 (update 3) / CenTos 3.3  2.4.21-15.EL  7000/8000  Native support included
RedHat AS/ES/WS 3 (update 3) / CenTos 3.3  2.4.21-15.EL  9500S/9550SX(U)/9590SE/9650SE Supported with KB A007354-082812 driver
 RedHat AS/ES/WS 3 (update 3) / CenTos 3.3  2.4.21-15.EL  9690SA Email request for support to support@lsi.com
 RedHat AS/ES/WS 3 (update 3) / CenTos 3.3  2.4.21-15.EL  9750  2.4 kernel not supported on the 9750
 RedHat AS/ES/WS 3 (update 4) / CenTos 3.4  2.4.21-27.EL  7000/8000  Native support included
 RedHat AS/ES/WS 3 (update 4) / CenTos 3.4  2.4.21-27.EL  9500S/9550SX(U)/9590SE/9650SE Supported with KB A007355-082812 driver
 RedHat AS/ES/WS 3 (update 4) / CenTos 3.4  2.4.21-27.EL  9690SA Email request for support to support@lsi.com
 RedHat AS/ES/WS 3 (update 4) / CenTos 3.4  2.4.21-27.EL  9750  2.4 kernel not supported on the 9750
 CentOS 3.4